TYPO3-Upgrade: Problem beim ändern der Compatibility-Version

|

Bei einem meiner Projekte habe ich eine Aktualisierung von TYPO3 4.1.7 auf 4.2.6 vorgenommen.

Bei einem Versionsprung dieser Größe muss man im TYPO3-Install-Tool den Update-Wizard aufrufen, der unter anderem die Kompatibilitäts-Version ändert, in diesem Fall auf 4.2.

Leider funktionierte das nicht, trotz merhmaligen Versuchen blieb die Version auf 4.1.

Erst ein Blick in die TYPO3-Konfigurationsdatei localconf.php brachte die Lösung:

folgende Zeile fand sich doppelt:

$TYPO3_CONF_VARS['SYS']['compat_version'] = '4.2';
.
.
$TYPO3_CONF_VARS['SYS']['compat_version'] = '4.1';

Das Install-Tool hatte also die alte Eintragung nicht überschrieben, sondern die neue Zeile vor der alten eingefügt, so daß die neue natürlich wieder mit dem alten Wert überschrieben wurde.

Ein manuelles Löschen der alten Zeile behob das Problem.

3 Gedanken zu “TYPO3-Upgrade: Problem beim ändern der Compatibility-Version”

Schreibe einen Kommentar

TYPO3 9 LTS Videotraining

Das Videotraining zu TYPO3 9 LTS

Momentan in Vorbereitung

Klicke hier für weitere Infos zum neuen Videotraining!

close-link
In Vorbereitung: Das Videotraining zu TYPO3 9 LTS
Hier klicken für mehr Informationen!
close-image

YouTube aktivieren?

Auf dieser Seite gibt es mind. ein YouTube Video. Cookies für diese Website wurden abgelehnt. Dadurch können keine YouTube Videos mehr angezeigt werden, weil YouTube ohne Cookies und Tracking Mechanismen nicht funktioniert. Willst du YouTube dennoch freischalten?