TYPO3-Tutorial Teil 44: Inhalte anlegen – Mail-Formular

Mit dem Inhaltselement „Mail-Formular“ lassen sich zum Beispiel Kontaktformular erstellen. So kann ein Besucher dem Seitenbetreiber Nachrichten zukommen lassen.
Viel Spaß!


[youtube]https://www.youtube.com/watch?v=O-SO1mMaUzs[/youtube]
Alle TYPO3-Tutorials kostenlos downloaden

Dieser Beitrag hat 17 Kommentare

  1. Michael

    Hallo,
    habe gerade das Mailformular a la Video (Nr. 44) erstellt. Funzt soweit auch, jedoch die Antwortseite kommt völlig ungestylt (d.h. ohne CSS-Formatierung) daher.
    Woran liegt das?
    mfg
    Michael
    P.S.
    Viiiiiiiiielen Dank für die Videos und die Arbeit die Du Dir machst. Finde ich großes Kino, was du da auf die Beine gestellt hast.

      1. Michael

        Hallo Wolfgang,
        DIESES Problem hat sich erledigt.
        Ich bin auf „Seiteneigenschaften“ auf „Erweitert“ gegangen und haben unter „Vorlagen-Design benutzen“ einfach das Standard-Layout eingegeben.
        ABER: etwas anderes habe ich bemerkt, als ich heute die Anmeldeseite anlegte:
        Auf allen Seiten der Topnav sowie auf der Unterseite „Danke für Ihre Nachricht“ ist auf der Navileiste nur „Home“ zu sehen. Alle anderen Menüpunte werden nicht angezeigt.
        What happend?
        Michael

        1. Schau dir die Videos zu den Navigationen noch mal an,
          wahrscheinlich hast du im Level 1 der Hauptnavigation den Parameter expAll=1 vergessen.

          1. Michael

            Yup! Das war’s.
            Witzig: Genau DIESES Video hab ich übersehen und übersprungen… fast wie in der Schule früher 🙂
            Eine Frage trotzdem noch:
            Bei Aufruf der Seiten „Kontakt“, „Impressum“ und „Inhaltsverzeichnis“ wird die Menüleiste fast doppelt so hoch wie sonst… ist da bei mir noch ein Typoscriptmurks drin?

  2. Wahrscheinlich, denn das dürfte nicht sein. Aber so kann ich nicht viel mehr drüber sagen. Kann man sich das online anschauen?

    1. Michael

      Leider nee… mach ich nur auf lokalem Server.
      Ich kann dir bestenfalls das Skript schicken, wenn dir das nciht zu viel Umstände macht.
      (per Mail?)
      Michael
      P.S.
      Sag mal, bis um wieviel Uhr sitzt du eigentlich immer am PC?

      1. Manchmal lang. 😉
        Anderer Vorschlag: komm doch in unser neues Forum, und schildere dort dein Problem, dort gibt es eine ganze Menge anderer TYPO3-Experten. Ich bin sicher, wir finden dort ne Lösung.
        http://webdesign-forum.net

  3. Alex

    Hi,
    arbeite seit kurzem mit Typo3, habe mir Tutorial angeschaut, nur sieht meine Oberfläche anders aus, viele Funktionen fehlen, woran liegt das?Ist die Typo3 Version zu alt?
    Danke für dioe Hilfe!

    1. Die Videos sind schon einige Monate alt und wurden mit inzwischen veralteten Versionen aufgenommen. Aktuell ist die Version 4.5.4, da gab es einige Änderungen. Allerdings hat sich am Funktionsprinzip nichts geändert, es sind mehr optische änderungen. Also einfach Augen auf und rumprobieren und im Zweifelsfall hier im Forum suchen oder fragen.

  4. Thomas

    Hallo Wolfgang,
    mit typo3 4.6 und der Standard Mail-Form bekomme ich nur:


    Contact us


    ###LABEL### ###FIELD###


    … kein Formular.
    Hast du eine Idee?
    Danke + Gruss,
    T

  5. Thomas

    Hi nochmal,
    ich weiss nicht, ob ich das uebersehen hab, aber bei mir war noch nicht das statische Template TS_Form eingebunden.
    Nachdem ich das gemacht hab, hat die Standard-Form zwar immer noch nicht funktioniert (leere Form wurde angezeigt), die „selbstgebaute“ funktioniert aber! 🙂
    Gruss,
    T

  6. Rainer R.

    Default TS (form).
    Das inkludieren dessen hat bei mir das Problem geloest. Danke Euch, dass der Hinweis hier gestatet wurde.
    Gruss
    Rainer

  7. Hanz Maaz

    Hallo Wolfgang,
    ich habe bei gleicher Typo3-Version ein Problem mit dem Mailformular.
    In einer Version erhalte ich den Formularassistent und kann schnell jedes Formular erstellen (zB):
    Ihr Name:
    | *Ihr_Name=input,40
     
    Ihre Email:
    | *email=input,40
     
    Ihre Nachricht:
    | Ihre_Nachricht=textarea,40,5
    | formtype_mail=submit | Nachricht absenden!
    | html_enabled=hidden | 1
    | subject=hidden | Testmail
    In der anderen Version erhalte ich einen „graphischen“ Assistent, mit dem ich kein Mailformular erstellen kann,
    sondern erhalte nur die Fehlermeldung:
    ###LABEL### ###FIELD###
    Wie kann ich den guten alten Assistent der ersten Version wieder eintellen ??

  8. Raymond

    Hallo Wolfgang
    Kann mann denn bei dem Mailformular auch wie z.B. bei Powermail einen Stern (*) vor dem Eingabefeld anzeigen lassen. Am Besten natürlich mit vergebener Klasse damit ich den Stern Visuell hervorheben kann.
    Das Problem bei dem Tool ist nämlich, dass der Benutzer nicht sieht ob und welche Felder Pflichtfelder sind.
    Gruss
    Raymond

    1. Kann ich dir leider gar nicht sagen, da ich meistens Powermail nutze oder ab TYPO3 4.7 auch manchmal die neue, mitgelieferte Form-Extension.

  9. Harald Fürschuß

    Hallo Wolfgang,
    ich habe noch einen alte TYPO3 4.4.3 Seite welche ich gerne um ein Kontaktformulat erweitern würde. Ich habe dein Tutorial duchrgearbeitet. Optisch sicht auch im Frontend alles so aus wie es sein soll, nur das ich keinen Mail versenden kann. Ich bekomme auch keine Fehlermeldung wenn ich auf den Submitbutton klicke und ein Pflichtfeld nicht ausgefüllt ist, dafür lädt aber die Seite jedes mal neu. Hast du eine Idee woran das liegen könnte? Vielen Danke im Vorraus. LG Harald

Schreibe einen Kommentar