Dieser Artikel ist über 1 Jahr alt. Deshalb könnten die Informationen hier veraltet sein.

10. Juni 2010

TYPO3-Tutorial Teil 23: Typoscript-Templates erzeugen

Geschätzte Lesezeit: 10 Sekunden

In Teil 23 des TYPO3-Einsteigerkurses erstellen wir ein Typoscript-Template für die ROOT-Seite. Außerdem werden vier weitere Templates erzeugt und in das ROOT-Template eingebunden.

Viel Spaß!

[youtube]https://www.youtube.com/watch?v=k7_2EM6_rsI[/youtube]

Alle TYPO3-Tutorials kostenlos downloaden

Artikel wurde gefunden mit den Suchbegriffen:
  • typo3 template erstellen
  • typoscript tutorial
  • typo3 typoscript tutorial
  • typo3 tutorial template
  • typo3 script tutorial
  • typo3 template erstellen anleitung
  • typo3 templates erstellen
  • the requested page didn\t have a proper connection to the tree-root!

Wolfgang Wagner

lebt in Friedrichshafen und arbeitet als Web Developer bei der TYPO3 Agentur jweiland.net in Filderstadt. Weitere Orte im Web: Twitter, Facebook, Videotraining zu TYPO3 8 LTS

Kommentare (20) Schreibe einen Kommentar

  1. auf der seite die du mir geschickt hast. Ansonsten nochmal hier:
    page = PAGE
    page.10 = USER
    page.10.userFunc = tx_templavoila_pi1->main_page
    page.10.disableExplosivePreview = 1

    Antworten

    • Du müsstest dann schon den Link zu dieser Seite hier posten, sonst kann ich da ntürlich nicht schauen 😉

      Wie sieht das restliche Typoscript aus? Und könntest du das unter dem ursprünglichen Kommentar posten, sonst kommen die Besucher hier drucheinander 😉

      Antworten

  2. Hallo,

    nun stehe ich vor dem nächsten Problem. Habe bisher alles wie in den Videos beschrieben wurde ausprobiert.
    Wenn ich nun auf ROOT und danach auf Template anklicke, sowie ein neues Template erstellen und auf speicher klicke, und danach auf Webseite anschauen klicke, erscheint folgendes:
    Error!

    The requested page didn’t have a proper connection to the tree-root!

    ()

    Was ja soviel heißt, wie, dass keine Verbindung zu meiner Root-Seite hergestellt werden konnte. Woher kann diese Ursache kommen?

    MfG Tobi

    Antworten

  3. Hallo,

    zunächst einmal vielen Dank für die Screencasts!!
    Ab diesem hier habe ich ein Problem:
    Beim Versuch die Vorschau des Templates zu öffnen (vgl Min 2:10 in deinem Video) erscheint bei mir folgende Fehlermeldung:

    TemplaVoila ERROR:

    Couldn’t find a Data Structure set for table/row „pages:73“.
    Please select a Data Structure and Template Object first.

    Viele Grüße
    Clemens

    Antworten

  4. Danke für die schnelle Antwort. Das war nicht das Problem…die ROOT-Zuweisung war gesetzt.
    Es funktioniert sobald ich nicht die Seite (vom Typ Verweis) ROOT als „Anfang der Website benutzen“ definiere sondern die darunterliegende Home Seite (und bei ihr alles wie im Video unter ROOT einstelle).
    Ich nutze die aktuelle 4.5.2 typo3 Version. Bei dieser gibt es nicht als absolute Wurzel eine Weltkugel sondern das typo3-Symbol. Darunter kann man dann neue Seiten erstellen…das ist mir so spontan aufgefallen.

    Antworten

  5. Hm, seltsam, ich habe auch eine 4.5.2er Seite, da bin ich so wie immer vorgegangen, ROOT unterhalb des TYPO3-Symbols, als Verweis auf Home, und ROOT als Anfang der Website. Bei mir geht’s. Ist denn der Verweis in ROOT auf Home richtig gesetzt und die Baumstruktur korrekt?

    Antworten

  6. Hallo Wolfgang,
    ich verwende die neueste typo3 Version 4.5.3 die ja doch erheblich anders aussieht. Ich dachte bisher, ich hätte alles gefunden und entsprechend eingestellt. Jetzt habe ich das gleiche Problem wie Clemens aber seine Lösung funktioniert bei mir nicht. Egal was ich mache, ich bekomme immer diese Meldung:
    TemplaVoila ERROR:

    Couldn’t find a Data Structure set for table/row „pages:1“.
    Please select a Data Structure and Template Object first.

    Ich habe absolut keinen Plan, wie ich weiter machen soll.
    Gruß

    Antworten

  7. Habe mittlerweile das Template auch direkt auf der HOME Seite angegeben und jetzt scheint es zu funktionieren.
    ???

    Antworten

  8. hallo wolfang,

    ich habe genau das gleiche problem wie jürgen über mir, jedoch geht es bei mir immer noch nicht, ich habe das template auch auf home angegeben. kannst du diesbezüglich helfen?

    Antworten

  9. Hallo,

    ersteinmal vielen Dank für Deine Arbeit. Ich bin wirklich beeindruckt.

    Ich versuche das Tutorial mit der Version 4.6.4 durchzuspielen jedoch rendert Typo3 unter „Template-Werkzeuge“ nichts.
    Wenn ich in das Modul „Template“ wechsle und dabei den Root-Knoten angewählt habe sehe ich zwar die Überschrift „Template-Werkzeuge“ aber sonst keine Inhalte.
    Sind die Punkte in der Version „umgezogen“?
    Einige andere Dinge konnte man immer schnell wiederfinden aber hier finde ich diesen Dialog einfach nicht.

    Antworten

  10. Mir fehlt übrigens auch „Mehrere Seiten erstellen“ unter Funktionen. Vielleicht hängt das zusammen?

    Antworten

    • Das „Mehrere Seiten erstellen“-Problem hat sich erledigt. Offenbar kamen bei mir func_wizards und wizard_crpages in der Installation nicht mit. Habe diese nachinstalliert und nun geht zumindest das.

      Antworten

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.