TYPO3-Tutorial Teil 06: Nachtrag zur ImageMagick-Installation

|

Hallo Leute,

leider ist mir bei der Installation von Image Magick ein kleiner Fehler unterlaufen.

Wie ich während der Vorbereitung des Tutorials über die eigentliche Installation von TYPO3 bemerkt habe, macht TYPO3 Probleme, wenn ImageMagick im Verzeichnis „C:\Program Files“ installiert ist. Das Leerzeichen in „Program Files“ wird von TYPO3 nicht akzeptiert.

Einfache Lösung: ImageMagick über die Systemsteuerung wieder deinstallieren, dann noch einmal neu installieren in einem beliebigen anderen Verzeichnis, z.B. in „C:\xampp\ImageMagick\“. Wichtig ist nur, daß kein Leerzeichen im Pfad erscheint.

Ich habe die Vorgehensweise im folgenden Video noch mal kurz gezeigt.

Sorry, dass ich euch doppelte Arbeit mache, dieser Fehler ist mir bisher nie untergekommen, da ich TYPO3 schon sehr lange nicht mehr unter Windows installiert habe. Tut mir leid!

Damit sind jetzt aber sämtliche Vorarbeiten abgeschlossen, und in Teil 7 geht es dann endlich mit der Installation von TYPO3 los. 😉

Alle TYPO3-Tutorials kostenlos downloaden

6 Gedanken zu “TYPO3-Tutorial Teil 06: Nachtrag zur ImageMagick-Installation”

  1. Hallo lieber Wolfgang.

    Ich habe eine Frage, wir machen alles von typo in einem ftp Verzeichnis und sind bei Inode und wir haben das Problem, dass wir das Image Magick nicht installieren können da der save mode eingeschalten ist. Und wir haben dort angerufen und deren Aussage war nur wir sollen in Google nachschauen weil das ist ein Fehler von Typo3 und ich weiß nicht wie ich das beheben soll. Auf die Frage ob sie den ausschalten können war die Antwort das sie das nicht können da sonst alle Kunden von ihnen gefährdet wären und das man das umgehen kann nur wie das funktioniert wissen die Leute anscheinend selbst nicht. Ich hoffe das du mit vielleicht dabei helfen kannst.

    Lg Steffi

    • Ich kann dir nur mit einem gut gemeinten Rat helfen: suche dir einen guten für TYPO3 geeigneten Hoster und ziehe mit der Seite dorthin um. Damit ersparst du dir garantiert künftigen Ärger und Kopfschmerzen.

      • nur bleibt für das leider keine zeit ich muss in 5 tagen fertig sein und ich habe herausgefunden das es einen bugtracker gibt dafür aber leider nur für eine ältere version von typo 3 aber vielleicht interessiert dich der link trotzdem oder andere haben das selbe problem
        http://bugs.typo3.org/view.php?id=17419

        Vielleicht helf ich ja dadurch jemanden es wird schon irgendwo eine passende Anweisung für meine Typo3 Version geben (hoffentlich =))

        Lg Steffi

          • das mit dem Link hat doch funktioniert ich habe nur nicht gewusst das ich die Datenbank umbenennen muss =)

            Nur habe ich jetzt das Problem das die Bilder alle viel zu klein sind und ich die Größe nicht definieren kann oder besser gesagt nicht finde wo ich das einstellen kann weil das Format ist von ImageMagick vorgegeben. Aber irgendwann werd ichs schon finden oder falls hier jemand eine Antwort hat ich freu mich sehr darüber =)

            Lg Steffi

    • Das Problem liegt daran das bei deinem Provider ImageMagick nur über PHP ansprechbar ist und Typo3 es somit nicht erkennt. Die einzigste Lösung die mir dazu einfällt wäre die Extension jb_gd_resize, diese lagert die Funktionen teilweise auf die gdlib aus, aber leider nicht alle. Du kannst es ja damit mal versuchen vielleicht hilft es dir ja.

Schreibe einen Kommentar

TYPO3 9 LTS Videotraining

Das Videotraining zu TYPO3 9 LTS

Momentan in Vorbereitung

Klicke hier für weitere Infos zum neuen Videotraining!

close-link
In Vorbereitung: Das Videotraining zu TYPO3 9 LTS
Hier klicken für mehr Informationen!
close-image

YouTube aktivieren?

Auf dieser Seite gibt es mind. ein YouTube Video. Cookies für diese Website wurden abgelehnt. Dadurch können keine YouTube Videos mehr angezeigt werden, weil YouTube ohne Cookies und Tracking Mechanismen nicht funktioniert. Willst du YouTube dennoch freischalten?