Dieser Artikel ist über 1 Jahr alt. Deshalb könnten die Informationen hier veraltet sein.

9. Juli 2010

TYPO3-Tutorial Teil 51: Nützliche Extensions – PowerMail

Geschätzte Lesezeit: 13 Sekunden

Das Standard-Mailformular von TYPO3 bringt nicht sehr viele Konfigurationsmöglichkeiten mit. Mit der Extension „PowerMail“ hingegen lassen sich sehr umfangreiche Formulare erstellen, die nicht nur zum Mailversand genutzt werden können.

Dieses Video ist dieses Mal in drei Teile gesplittet.

Viel Spaß!

 

Teil 1

 

Teil 2

 

Teil 3

Alle TYPO3-Tutorials kostenlos downloaden

Artikel wurde gefunden mit den Suchbegriffen:
  • powermail tutorial
  • typo3 powermail tutorial
  • powermail Error: Powermail - Typoscript nicht vorhanden!
  • powermail
  • typo3 powermail
  • powermail typo3
  • address in mailbox given [] does not comply with rfc 2822 3 6 2
  • typo3 powermail anleitung

Wolfgang Wagner

lebt in Friedrichshafen und arbeitet als Web Developer bei der TYPO3 Agentur jweiland.net in Filderstadt. Weitere Orte im Web: Twitter, Facebook, Snapchat

Kommentare (87) Schreibe einen Kommentar

  1. Hallo Wolfgang
    Ich habe alle Ihre Videos gesehen und sind gut, ich möschte wiessen wie folgt mit dem powermail ein Video erklärt, wie man Web-Seite in meinem andre sprache machen kann otosmein defaul ist español Ich mag in deutscher und englischer Sprache nehmen würde
    Vielen Dank
    Francisco
    Escuchar
    Leer fonéticamente
    Diccionario – Ver diccionario detallado

    Antworten

  2. Hallo,

    ich hab mir powermail mal runtergeladn, installiert und ein wenig experimentiert.

    Nun habe ich aber ein kleines Problemchen. Ich habe ein Kontaktformular erstellt und habe auch eingestellt, dass derjenige der das Formluar ausfüllt, eien Bestätigungsemail erhält.
    Betreff und Inhalt der Email passen. Aber Von: passt nicht. Von: „powermail“ .
    Zum einen möchte ich dort nicht Powermail stehen haben, zum anderen eine andere Emailadresse. Ist dies möglich, wenn ja wo? Oder bin ich einfach zu doof zum finden 😉

    Kann ich Powermails auch für mehrere Formulare auf einer Webseite verwenden?

    MfG Tobi

    Antworten

    • Das ist ein altes Problem von Powermail. Füge mal folgendes Typoscript in dein Setup ein:

      plugin.tx_powermail_pi1 {
      markerALL.hideLabel = 1
      # Some settings for Emails
      email {
      sender_mail {
      # Sender name (overwrite)
      sender.name = TEXT
      sender.name.value = Vorname Nachname
      }
      }
      }

      Und ja, du kannst beliebig viele Formulare erstellen.

      Antworten

  3. Wenn das ein altes Powermail-Problem ist, warum behebt der Entwickler das Problem dann nicht?

    Was genau meinst du mit Setup?

    Welche Email-Adresse wird dann genommen? Die die im Konstanten-Editor hinterlegt ist?

    Antworten

    • In dein Typoscripttemplate. Die Emailadresse ist dann die, die du als Empfänger für das Formular eingibst, also deine Adresse.

      Warum der Entwickler das nicht behebt, weiss ich nicht, schreibe ihm doch mal ne Mail 😉

      Antworten

  4. Hi habe jetzt endlich alles eingerichtet und angelegt- Leider kommt werder eine E-Mail an noch wird eine Benarichtigung versendet. Muss die Absender Adresse die URL des Servers-Typo3 haben oder kann eine beliebige rein. Kann Versender und Empfänger für Testzwecke gleich sein. An welche Stelle kommt der Typoscript von oben rein ins Setup ?

    Antworten

    • Hallo,

      hast du bei Empfänger eine Emailadresse eingeben?
      Findest du eine abgesendete Email in dem dazugehörigen Sys-Ordner vor?

      Zum Setup:
      Template -> ROOT -> Info/Bearbeiten -> Setup und dann kannst du die Zeilen einfügen:
      plugin.tx_powermail_pi1 {
      markerALL.hideLabel = 1
      # Some settings for Emails
      email {
      sender_mail {
      # Sender name (overwrite)
      sender.name = TEXT
      sender.name.value = Vorname Nachname
      }
      }
      }

      Vorname und Nachname mußt du dann nur noch mit deinen Austauschen.

      Antworten

  5. Ja der Sysordner ist voll von meinen Testmails – ja ich habe bei Ausgang und Eingang eine Mail eingerichtet – immer die gleiche ? Ist der sender.name eine Pflicht Variable oder nur ein Platzhalter ? Danke ersteinmal werde mich gleich dran machen

    Antworten

  6. Naja wenn du sendet.name nicht umänderst, dann steht bei der Email im Posteingang Von: „powermail“ und deine Emailadresse und dass möchtest du ja denke ich auch nicht.

    Funktioniert dein Mailsserver?

    Antworten

  7. ich habe eine Adresse von Web de angegeben – dashalb ja meine Frage ob die Mail Ausgangsadresse an den Server angebunden sein muss oder irgend eine Adresse – wenn ja haben wir das Problem muss evtl. in der Typo3 config was angepasst werden – da stehen einige sachen mit Mailsysten ?

    Antworten

    • Als Absendermail kannst du eine beliebige eigene Emailadresse nehmen, egal bei welchem Anbieter, da TYPO3 ja nicht auf diesen Mailserver zugreift. Die Empfängermail kann auch beliebig sein.

      Funktioniert denn generell der Mailversand auf deinem Webspace? Im Installtool in der Basic Configuration gibt es dafür einen kleinen Testbutton.

      Antworten

  8. Hi ne sorry ist ein anderes Projekt ich arbeite an meiner Privateb Seite :-Wie gesagt der Mailversang geht soweit das die Anfragen im StorageOrdner angelegt werden – auch die Absender und Empfänger Adressen sowie der Text wird Angezeigt auch die Tolle Grafik mit der Statistik füllt sich mit meinen Testmails. Es geht irgenwie eben nicht aus Typo3 raus. Ich habe die oben genannte Quellcode ins Setup eingebunden -ganz unten ? aber es geht leider einfach nicht —

    Antworten

  9. es geht ich werde verrückt

    Sehr geehrter Hendrik,
    Danke für Ihre Anfrage.
    ersetzen Sie in der Datei /t3lib/utility/class.t3lib_utility_mail.php
    $success = @mail($to, $subject, $messageBody, $additionalHeaders, $additionalParameters);
    durch
    $success = @mail($to, $subject, $messageBody, $additionalHeaders);
    mfg

    Hendrik

    Antworten

    • Wie ich dir schon per Mail geschrieben habe, halte ich Änderungen an TYPO3-Core Dateien nicht für den richtigen Weg, da die beim nächsten Update wieder weg sind.

      Such dir einen für TYPO3 geeigneten Provider.

      Antworten

  10. Danke Wolfgang für Hilfe und das gute Tutorial, mich würde sehr interessieren wo ich das Aussehen der Seite etwas anpassen kann. Du hast über Klassen und Id – wo liegen die bzw. wird ein Template erzeugt oder wo bzw. wie ändere ich es.

    Antworten

    • Wenn du das Grundlayout der Seite meinst: dafür solltest du dich ausführlich mit dem verwendeten Framework YAML beschäftigen. Die Dokumentation auf der Website ist sehr gut.

      Im Rahmen dieser Tutorials gehe ich darauf nicht ein, da sich der Kurs mit TYPO3 beschäftigt.

      Aber wenn du dir mal meine Referenzen anschaust, siehst du, dass alle auf YAML basieren. Man ist also durch die Verwendung des Frameworks in keinster Weise eingeschränkt.

      Antworten

  11. Ja danke ich habe die Standart CSS Datei gefunden und angepaßt – reicht mir fürs erste – das war auch meine eigentliche Frage wo die Dateien liegen. Natürlich kenne ich YAML aber warum mit Kanonen auf Spatzen schießen ich wollte nur einen Farbwert anpassen 🙂

    Antworten

    • Es gibt im Prinzip zwei Dateien, die das Aussehen der Seite regeln: die basemod.css, die die Positionierung der Container usw. regelt, und die content.css, in welcher alle schriften, Farben usw. angepasst werden.
      Du kannst natürlich, wenn das Layout steht, aus Performancegründen die einzelnen CSS-Dateien in einer zusammenfassen.

      Antworten

  12. Hallo Wolfgang, ich stelle hier noch einmal meine beiden Fragen falls andere auf das gleiche „Problem“ gestoßen sind:
    1. Frage: die Benutzung von Markierungsfeldern im Formular (z.B. Häkchen bei „Ja“ oder „Nein“) macht mir beim Excel-Export Probleme: Die entsprechenden Daten tauchen zwar in der exportierten Tabelle auf aber unter der falschen Spaltenüberschrift, denn die richtige Überschrift fehlt einfach. So „rutschen“ also die Überschriften der nachfolgenden Spalten nach links, so dass dann auch alle nachfolgenden Daten unter einer falschen Überschrift stehen. Kann man das verhindern?
    2. Frage: kann man Felder im Formular auch erst „erscheinen“ lassen, wenn zuvor in einem anderen Feld eine bestimmte Auswahl getroffen wurde? (Bsp. „Reservierung gewünscht?“ -> „Ja“ -> Neue Felder „Ankunftsdatum“, „Zimmeranzahl“ etc.)
    Vielen Dank & viele Grüße, Wolf

    Antworten

  13. Pingback: Mails kommen nicht an - TYPO3 Forum & Portal

  14. Hallo Wolfgang, erst mal ein großes Lob für das tolle Tutorial!

    Leider habe ich wohl irgendwo einen Fehler gemacht 🙁

    In meinem Konstanten-Editor vom Root-Template habe ich nicht die Möglichkeit auf die Erweiterungen zuzugreifen.

    In meiner Typo3 (4.5) Installation werden mir nur die Punkte Content und Advanced angezeigt.

    Was könnte ich falsch gemacht haben?

    Viele Grüße!

    Antworten

  15. Ich hatte das selbe Problem wie Jörn. Im Video zu Powermail 1 wird der Punkt der statischen Templates der verwendeten Extension aber nicht angesprochen bevor du den Konstanten-Editor öffnest.
    Nach der Installation der vorherigen Extensions hätte man darauf aber auch selbst kommen können.
    Jetzt kann ich weitermachen. Danke an Jörn für die Frage und natürlich an Wolfgang für dieses geniale Projekt.

    Grüße

    Antworten

      • Es scheint so als wäre die Version einfach nur aktualisiert worden. Ich habe Version 1.6.0 installiert.

        Diese Version verfügt auch über ein zusätzliches CSS Design namens Powermail fancy css (powermail).
        In Teil 2 oder 3 ist der Eintrag den ich machen musste bei dir auch nicht zu sehen.
        Aktuell habe ich 2 Einträge im ROOT Template für Powermail:
        Powermail (powermail)
        Powermail basic css (powermail)

        Gruß

        Sascha

        Antworten

  16. In video 1 on 2:40 min you go to Template > Root > constant Editor > and select category Plugin PowerMail config.

    But I don’t see this option after I have installed Powermail.

    Antworten

  17. And after installation of Powermail I get the next error message when I make an Powermail content element:

    ERROR: Content Element type „powermail_pi1“ has no rendering definition!

    Antworten

  18. Hallo Wolfgang,

    Bei typo3.4.5 und Powermail 1.6 gehen die Powermail static template nicht

    Erweiterungs-Manager
    Ergebnis des Erweiterungsimports

    Abhängigkeitsfehler

    Die aktuelle Version der Erweiterung „powermail“ (1.6.0) ist höher als erlaubt.
    ??? Versionserfordernis ignorieren ???

    Antworten

  19. Hallo,

    gibt es noch Tips für gute weiterführende Tutorials um komplexere Formulare zu basteln ?

    Danke vorab.

    Gruß,

    Samuell

    Antworten

  20. Frage???
    Habe powermail installiert wird im WEB-Modul angezeigt. Nun habe ich das Problem das der Eintrag PLUGIN_POWERMAIL_ nicht im Kosnstanten-Editor angezeigt wird. Also folglich kann ich keine Einstellungen machen. Nutze powermail 1.6.3 !

    Danke vorab.

    Antworten

      • erst mal danke für die schnelle Reaktion!
        Enweder bin ich blind aber ich finde nicht den Reiter wo ich dies machen kann.
        Dies habe ich gefunden!
        Modul Web > List view
        Page tree: Your root page or your page, where you need powermail only.
        TypoScript template > tab [Includes]
        Field [Include static (from extensions):]: Add the powermail templates

        sowie ich das verstanden habe:
        ins LIST modul gehen
        auf die Seite gehen z.B. Kontakt
        Datensatz bearbeiten hier steht im Typ Powermail aber wo habe ich den Reiter Enthät ???

        Antworten

        • Nein. Du gehst in das Modul „Templates“, dann auf deine Root-Seite. Klicke dann in der rechten Spalte im Pulldown-Menü auf „Info/Bearbeiten“. Dann weiter unten auf „Vollständigen Datensatz bearbeiten“. Dann auf den Reiter „Enthält“. Und füge dort dann die Powermail-Templates deinem Template hinzu. Speichern, und jetzt sollte das ganze im Konstanteneditor zu sehen sein.

          Antworten

  21. habe es gerafft!
    bei mir steht einmal powermail (powermail) und einmal Static Info Tabels
    erst habe ich es mit beiden Einträgen probiert dann nur mit dem Eintag powermail.
    Nun sehe ich die Einstellungen im Konstanten Editor.

    Vielen Dank an dich Wolfgang und natürlich auch für dein gutes Tutorial was mir Typo näher bringt.

    Gruß Christian

    Antworten

  22. neues Problem aufgetaucht :-((
    warum werden mir in meinem Seitenmodul meine Seiten nicht mehr angezeigt?
    Außerdem wurde mir im powermail auch nicht die Vorschau angezeigt.
    Ich bekomme diese Meldung im List Modul:
    The requested page didn’t have a proper connection to the tree-root!

    Gruß Chris

    Antworten

    • Dazu müsste ich mehr Infos haben und auch mal eine Blick auf deinen Seitenbaum werden können.

      Vorschlag: schildere das Problem mal hier im Forum, am besten gleich mit einem Screenshot des Seitenbaumes und vielleicht deines Navigations-Typoscripts. Und auch, wie und wann das Problem aufgetaucht ist. Da dort noch viele andere kompetente User sind, sollten wir eine Lösung finden können 😉

      Antworten

  23. Hallo,
    Frage wegen meinem Seitenbaum der plötzlich weg ist. Habe zuletzt mit powermail Daten eingetragen wie im Videotutorial 51 Teil 2 beschrieben hier gab es auch schon das Problem das die Powermailvorschau nicht angezeigt wurde. Nun habe ich im Anzeige Modul folgende Meldung:
    Uncaught TYPO3 Exception
    The requested page didn’t have a proper connection to the tree-root!

    RuntimeException thrown in file
    E:\xampp\htdocs\typo3\sysext\cms\tslib\class.tslib_fe.php in line 1079.

    Wenn ich zum anderen Benutzer wechsel der mir als xxxx0 angezeigt wird sehe ich den Seitenbaum.
    Im Kontakt-Link auf der Webseite bekomme ich folgendes angezeigt:
    The requested page does not exist!

    RuntimeException thrown in file
    E:\xampp\htdocs\typo3\sysext\cms\tslib\class.tslib_fe.php in line 1030.

    was ist hier wohl los ????

    Danke für eure Antwort

    Antworten

  24. Reference Index being TESTED
    1639 records from 29 tables were checked/updated.
    Index Integrity was perfect!
    leider halfen die Links nicht weiter da das eine fehlerhafte RealUrl beschreibt und der andere Efekt bei einem Update passierte was hier nicht der Fall war.

    M.f.G.
    chris

    Antworten

  25. Das mit dem Seitenbaum ist wieder klar, da war mal wieder der DAU vorm PC 😉
    Hab nur noch das Problem das mir die Vorschau im powermail nicht angezeigt wird.

    Gruß Chris

    Antworten

    • Und woran lag es jetzt?

      Warum die Vorschau nicht erscheint, kann ich dir leider nicht sagen, dieses Feature schalte ich bei mir immer aus, da ich es nicht benötige. Vielleicht ist es bei dir auch deaktiviert? Klicke mal im Extension Manager auf den Namen der Extension, dann landest du in den grundlegenden Einstellungen. Hier kann man die Vorschau ein- oder ausschalten.

      Antworten

  26. Hallo Wolfgang, ganz einfach ich stand wohl auf dem Root und hatte den Seitenbaum eingeklappt auf dem Root konnte nichts angezeigt werden da hier keine Seite definiert war folglich auch Fehlermeldung in Ansicht da die erste Seite im Homeverzeichnis definiert war aber da der Baum eingeklappt war habe ich vermutet das mein ganzes Verzeichnis weg war.
    Nun zur anderen Sache mit powermail, hier konnte ich Daten eintragen aber wenn ich mir die Webseite ansehe bekomme ich keine Anzeige sondern nur diese Fehlermeldung. Folge dessen in der Vorschau und auf der Webseite unter Kontakt keine Anzeige.

    Danke nochmal für deine Antworten, es ist schön wenn es Menschen gibt die sich der Belangen von Problemen annehmen wie du.

    Gruß chris

    Antworten

  27. Moin moin,
    also erstmal ein riesiges Lob für diese super strukturierte Reihe von tollen Videos.

    Allerdings ist bei mir nun doch ein Problem aufgetreten welches auch die große Suchmaschine nicht lösen konnte:
    und zwar hab ich das Formular mit dem Powermailer genauso eingerichtet. Bei mir läuft das ganze auf einem Webserver. Wenn ich dann auf abschicken komme erscheint die Fehlermeldung:
    „Oops, an error occured!

    Address in mailbox given [] does not comply with RFC 2822, 3.6.2.“
    nutze Typo3 4.5

    gibt es da Abhilfe? danke jetzt schonmal

    Antworten

    • Folgendes im Konstantenfeld im Template ausfüllen sollte helfen:

      plugin.feadmin.dmailsubscription {
      # cat=plugin.feadmin.dmailsubscription//; type=string; label= Administration email: Enter the administration email address here. This email address will be the sender email and also recieve administration notes.
      email =
      # cat=plugin.feadmin.dmailsubscription//; type=string; label= Administration name: Enter the administration name here. If set, this will be used as the email address name in the mails sent.
      emailName =
      }

      Antworten

  28. Seit TYPO3 4.5 wird ein anderes Skript für den Mailversand verwendet.
    Such mal im Installtool nach dem Eintrag [MAIL][substituteOldMailAPI] und aktiviere die MailAPI. Geht es dann?

    Antworten

  29. Hallo Wolfgang,

    auch von mir erstmal ein großes Lob für die tollen Video-Tutorials.

    Ich habe TYPO3 version 4.1.6 und wenn ich Powermail installiere und ignoriere, das ich eine ältere Version habe, bekomme ich die Fehlermeldung, das das Typoscript fehlt.

    Hast Du da einen Lösungsansatz für mich?

    MfG Andi

    Antworten

  30. Problem mit Konstanten Editor

    Hi
    Ich habe Powermail installiert und auch das statische Template im Root eingebunden.
    Leider zeigt mir der Konstanten Editor immer noch nicht powermail an.

    Habe ich was vergessen?

    TYPO3 4.4.4
    powermail 1.6.3

    Antworten

  31. Probleme mit Powermail

    Nach der Installation wie im Video beschrieben, funktioniert auch alles. EMails kommen an, Bestätigungs-EMails werden versendet und im Listenmodul auf dem Powermail-Storage werden auch alle EMails angezeigt.
    Nur im BE Powermail ist die Liste leer. Eigenartigerweise kann ich aber den „Leeren Inhalt“ als HTML oder CSV exportieren und bekomme auch alles angezeigt. Nur eben nicht im BE-Powermail.

    Version Typo3 4.5.3
    Powermail 1.6.3

    Irgendeiner eine Idee was falsch sein könnte.

    MfG
    Heinz-Rolf

    Antworten

  32. Hallo Wolfgang,
    Kompliment für Deine tolle Videoserie.
    habe gerade nach Deiner Anleitung powermail 1.6.4 unter TYPO3 4.6 installiert. Leider kann ich keine Formularseiten anlegen. Bei mir erscheint der Link 2x oberhalb der Vorschau. Wenn ich drauf klicke passiert….nichts! Hast einen Tipp für mich?

    LG
    Andreas

    Antworten

  33. Hallo,

    habe das gleiche Problem!

    Version Typo3 4.6.1
    Powermail 1.6.4

    Ich bekomme wenn ich die Formularseite stellen will die folgende Fehlermeldung:
    Powermail-FEHLER: Bitte gehen Sie zurück in den Erweiterungsmanager, wählen die Erweiterung powermail und drücken die Schaltfläche „Update“!

    Da ist aber nichts, wo ich ein Update machen kann.
    Hat einer nen Tipp?

    Gruß Manuel

    Antworten

    • Gehe in den Erweiterungsmanager, klick auf den Namen der Erweiterung, dann öffnet sich ein neuer Bereich mit verschiedenen Reitern. Klicke dort auf „Konfiguration“ und dann dort ganz unten auf „Aktualisieren“ oder „Update“, je nach dem, ob dein Backend in Deutsch oder Englisch ist.

      Antworten

  34. Hi,
    bei mir funktioniert Powermail super, und habe es auch schon grafisch angepasst. Nur habe ich ein Problem:
    Wenn ich meine Daten eingegeben habe und auf Abschicken gehe, dann kommt die Bestätigungsseite auf englisch.
    in TS habe ich aber meta.LANGUAGE = de eingetragen und im Browserquelltext steht dann auch mein META drin.
    Bei mir ist alles auf deutsch und trozdem bekomme ich die Bestätigungsseite auf englisch.
    Woran kann das denn liegen?
    Danke für die Mühe im Voraus 🙂

    Antworten

  35. Das Ganze hier ist ein sehr hilfreiches Tutorial.

    Ich habe Powermail eingerichtet, will auch Double-opt-in verwenden, habe die Typo3 Version 4.5.10.

    auf meinem „Powermail-Storidge“-Ordner kommt auch was an, es geht aber keine Mail raus, weder an den Empfänger, noch an den Absender.

    Was kann ich tun?

    Antworten

        • Vielleicht mal den Provider kontaktieren, warum der Mailversand über PHP nicht geht.

          Man kann glaube ich auch irgendwo im Installtool seine SMTP-Zugangsdaten hinterlegen, aber da bin ich mir gerade nicht sicher.

          Antworten

          • Also zunächst erst mal: Vielen Dank für die Hinweise.

            Ich habe meinem Provider den Vorgang komplett geschildert mit der ersten Antwort: „Ich kenne Powemail nicht“
            Nach genaueren Schilderungen bekam ich dann die mail: „…wir haben eine Modifikation der php.ini gemacht…“

            So, jetzt gehen mails raus.
            Zum Opt-in: Die Bestätigung-Mail hat den Absender „Powermail“. ich habe das o.g. TypoScript im Setup eingebunden – Absender: „powermail“
            Der Bestätngings-Link führt zur Seite mit der Fehlermeldung:
            „Folgende Fehler sind aufgetreten:
            Der eingetragene Code war leider falsch – zurück zum Formular“

            Technik: Typo3 4.5.10, Powermail-aktuell, zusätzliche Extension: „captcha“

            Mein Provider hat eine Grundinstallation in seinem Software-Paket: Typo3 4.4.2

            Ich habe das Projekt quasi gedoppelt.

            Powermail läuft im BE mit fehlerhaften deutschen Umlauten und Sonderzeichen. Das „Capcha“ wird nicht angezeigt, nur das dazugehörige Eingabefeld – ist also unbrauchbar.

            Ich muss nirgends SMTP-Zugangsdaten hinterlegen (also schonmal ein großer Vorteil)

            Aus dem Ganzen ergibt sich aber noch ein ganz anderes Problem:
            ImageMagick läuft /angeboten vom Provider = vorinstalliert auf 4.4.2

            Nach dem upgrade auf 4.5.10 (weil ich ja eigentlich eine höhere Version für Povermail brauche) lässt sich in keinster Weise mehr auf ImageMagick zugreifen, ensetzen, installieren o.ä.

            Wenn es sich nicht um einen renomierten Kunden handeln würde, hätte ich nicht so viel Energie da reingesteckt!

  36. Hallo in die Runde,
    zunächst mal wieder ein riesen Kompliment, man kann es einfach nicht oft genug sagen. Ich habe mich jetzt von Screencast 1 bis hierher chronologisch durchgearbeitet, nachdem ich zwischenzeitlich schonmal einzelne Videos geschaut hatte und man kann wirklich jedes Lehrbuch in die Tonne kloppen!!
    Aber genug der Lobhudelei, ich wollte ja auch eine konkrete Frage stellen:
    Wie schon einige Vorredner habe ich powermail 1.6.4 unter TYPO3 4.6 installiert und hatte Anfangs das Problem, dass mir im Konstanten-Editor für Root in der Selectbox zur Kategorie die Powermail-Konfigurationsmöglichkeiten nicht angezeigt wurden … ich habe ein wenig rumprobiert und nachdem ich Powermail Basis CSS, Powermail Fancy CSS und Powermail in den statischen Templates hinzugefügt hatte UND oben den Haken bei „Statische Templates nach Basis-Templates einfügen“ gesetzt habe, funktioniert es auf einmal. Ehrlich gesagt, weiß ich aber nicht genau warum eigentlich … War das ein Cache-Problem, oder muss man da in Typo3 4.6 tatsächlich noch weitere Punkte beachten? Danke für ein kurzes Statement.
    Gruß
    Christian

    Antworten

      • Hmm, ich hege bald die Vermutung, dass sich der Cache nur „irgendwie“ verheddert hat. Ich habe das Häkchen wieder deaktiviert und auch nur das Basiselement vom PowerMail eingefügt und es läuft immernoch …
        Sowas liebe ich ja … trotzdem danke für die prompte Antwort! Fazit: Typo3 4.6 macht eigentlich keine Probleme mit dem aktuellen PowerMail.
        Gruß
        Christian

        Antworten

  37. @Ralf Braun

    Ich kann dir nur ans Herz legen, dir selbst einen Gefallen zu tun und deinen Kunden zu überzeugen, mit der Seite zu einem für TYPO3 spezialisierten Hoster umzuziehen.

    Antworten

    • Der Kunde hat standardmäßig 1&1. Jetzt habe ich gelesen, daß es dort etwas schwieriger sei das Paket zu installieren. Hat jemand da Erfahrung?

      Antworten

      • Oh ja, damit habe ich Erfahrung, und mein Fazit lautet: 1&1 + TYPO3 = unnötiger Ärger. Überzeuge deinen Kunden, zu einem vernünftigen Hoster zu wechseln, das erspart dir Kopfschmerzen und deinem Kunden auf lange Sicht Geld und Ärger. Glaube mir 😉

        Antworten

  38. Hallo,

    ich habe powermail 1.6.4 mit der Erweiterung double-optin 1.0.1 eingerichtet und dabei 2 Probleme:

    1. Gebe ich im Powermailformular (FE) einen Absender ein, der zugleich Empfänger des Formulars ist, wird keine OptIn eMail verschickt.

    2. setze ich den Absender der Doubleoptin eMail auf noreply@… ein
    plugin.tx_powermailoptin.email.senderEmailOverwrite = noreply@irgendwas.de, sendet Freenet die Bestätigungsmail nicht zurück. „sender“ ist definiert: plugin.tx_powermailoptin.email.senderOverwrite = irgendwas

    (Hoffentlich verständlich formuliert)

    Woran liegt das?

    gruss Günter

    TYPO3 4.5.x

    Antworten

  39. Hy Wolfgang,

    erstmal einen rießengroßen Dank an dich, deine Tutorials sind echt spitze! Hab mir schon fast alle angeschaut 🙂

    Ich sitzte gerade bei einem Problem bei dem ich nicht weiterkomme.
    Hat zwar mit Powermail eigentlich nichts zu tun, aber die Fehlermeldung kommt immer nur wenn ich auf dem Frontend mit Powermail eine E-Mail verschicken will.

    Sprich das Kontaktformular steht ist soweit fertig konfiguriert und gestylet, fülle die notwendigen Daten in das Formular ein und drücke auf senden – es wird mir noch die Seite angezeigt auf der man „Angaben abschicken“ klicken kann und danach kommt folgende Meldung:

    Fatal error: Class ‚Swift_Mime_Headers_ParameterizedHeader‘ not found in /data/web/e29630/html/ptshome/typo3/contrib/swiftmailer/classes/Swift/Mime/SimpleHeaderFactory.php on line 114

    Ich hab schon im Internet gestöbert und auch ein paar SimpleHeaderFactory.php Dateien gefunden. Aber nach einem Vergleich meiner Datei mit den „default“ Dateiein keinen inhaltlichen Unterschied gefunden.

    Was noch wichtig wäre ist ich arbeite mit Typo 4.6.1 und powermail 1.6.4.
    Außerdem habe ich die TYPO3 Seite voerst lokal auf meinem Laptop erstellt und durchgestyled und letzte Woche auf den Webserver hochgeladen.
    Bis auf das Kontaktformular funktioniert alles soweit 🙁
    …hoffe du kannst mir helfen oder einen Tipp geben wie ich diesen Fehler behebe!!

    Liebe Grüße
    Georg

    Antworten

    • Hm, sorry, diese Fehlermeldung sagt mir jetzt auf die Schnelle auch nichts. Ich würde vorschlagen, du beschreibst den Fehler und deine Vorgehensweise vor dem Fehler mal hier im Forum, wir haben da einen Haufen TYPO3-Experten, vielleicht kann einer weiter helfen.

      Antworten

      • naja…Fragen kostet nix 😉

        danke für den Link, werd´s dann mal in den Foren testen.

        Liebe Grüße
        Georg

        Antworten

  40. Hallo Wolfgang,

    ich habe ein Problem mit der CSV-Datei. Wenn eine Frage mit Radio-Button nicht beantwortet wird, bleibt das entsprechende Feld in der Tabelle nicht leer, sondern wird mit der nächsten Antwort gefüllt.So bekomme ich keine Struktur in die Tabelle, sprich Frage und Antwort passen nicht zusammen. In der HTML-Ansicht ist dagegen alles wunderbar.

    Kennst Du das Problem? Hast Du eine Ahnung, wo ich da ansetzen könnte?

    Vielen Dank und beste Grüße,
    Fabian

    Antworten

  41. Hallo Wolfgang,
    herzlichen Dank für das güte tutorial.
    Ich benuze Powermail 2.0.6 und typo3 4.7.
    Ich bekomme jetz diese Fehler in FE:

    #1316104317: The default controller for extension „Powermail“ and plugin „Pi1“ can not be determined.

    Antworten

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.